PowerReport
  1. PowerReport
  2. PWR-74

Unable to see report in PowerReport gadget

    Details

    • Type: Support Request Support Request
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.3.1
    • Fix Version/s: 1.0.3.2
    • Component/s: None
    • Labels:
      None
    • Environment:
      JIRA 5 WAR installed on Tomcat 6.0.35, Birt 3.7.0 on same machine. MS Windows, Apache Proxy, PostgreSQL

      Description

      I can't see any report in PowerReport gadget. It shows completely blank frame (with no HTML code within).
      PostgreSQL drivers has been copied into /lib directory.
      We're using birt viewer packed by Valiantys.

      1. atlassian-jira.log
        92 kB
        Robert Dzido
      2. birt.xml
        0,6 kB
        Robert Dzido
      3. powerReportConfiguration.properties
        3 kB
        Robert Dzido
      4. System Info - printout.pdf
        111 kB
        Robert Dzido
      5. web.xml
        7 kB
        Robert Dzido
      6. web.xml
        7 kB
        Robert Dzido
      1. screenshot.jpg
        370 kB
      2. screenshot-1.jpg
        72 kB
      3. screenshot after web.xml change.jpg
        418 kB
      4. sshot.jpg
        65 kB
      5. System Info - 1.jpg
        254 kB

        Issue Links

          Activity

          Brice Gestas [Valiantys]
          added a comment -

          Hi Robert,

          Which Web Browser are you using?

          Regards

          Show
          Brice Gestas [Valiantys]
          added a comment - Hi Robert, Which Web Browser are you using? Regards
          Robert Dzido
          added a comment -

          MSIE 8 and Firefox 10. Tested on both with same result. No firewall or antivirus software were enabled. JIRA, BIRT and client browser on same local machine.

          Show
          Robert Dzido
          added a comment - MSIE 8 and Firefox 10. Tested on both with same result. No firewall or antivirus software were enabled. JIRA, BIRT and client browser on same local machine.
          Brice Gestas [Valiantys]
          added a comment -

          Ok,

          Is there any log exception in your "atlassian-jira.log" file concerning that problem?

          Regards

          Show
          Brice Gestas [Valiantys]
          added a comment - Ok, Is there any log exception in your "atlassian-jira.log" file concerning that problem? Regards
          Robert Dzido
          added a comment -

          I can't see anything wrong in log file.
          WARNings are about our confluence working on another tomcat@wiki.promity.dom

          Show
          Robert Dzido
          added a comment - I can't see anything wrong in log file. WARNings are about our confluence working on another tomcat@wiki.promity.dom
          Brice Gestas [Valiantys]
          added a comment - - edited

          Hi,

          Another issue has been created concerning that problem (see link).

          You can be watcher of this new issue to keep you updated of its evolution.

          Regards

          Show
          Brice Gestas [Valiantys]
          added a comment - - edited Hi, Another issue has been created concerning that problem (see link). You can be watcher of this new issue to keep you updated of its evolution. Regards
          Clément Capiaux [Valiantys]
          added a comment -

          Hi Robert,

          This has been fixed in the new version, and can be downloaded following this link :

          ==> https://plugins.atlassian.com/plugins/com.valiantys.jira.plugins.reporting/version/9374

          Best regards,
          Clément

          Show
          Clément Capiaux [Valiantys]
          added a comment - Hi Robert, This has been fixed in the new version, and can be downloaded following this link : ==> https://plugins.atlassian.com/plugins/com.valiantys.jira.plugins.reporting/version/9374 Best regards, Clément
          Robert Dzido
          added a comment -

          After installing (and configuring .properties file) I got error like this. Screenshot attached

          HTTP Status 500 -

          type Exception report

          message

          description The server encountered an internal error () that prevented it from fulfilling this request.

          exception

          javax.servlet.ServletException: Error instantiating servlet class org.eclipse.birt.report.servlet.ViewerServlet
          org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
          org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
          org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
          org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
          java.lang.Thread.run(Thread.java:662)

          root cause

          java.lang.ExceptionInInitializerError
          org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58)
          sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
          sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
          sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
          java.lang.reflect.Constructor.newInstance(Constructor.java:513)
          java.lang.Class.newInstance0(Class.java:355)
          java.lang.Class.newInstance(Class.java:308)
          org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
          org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
          org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
          org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
          java.lang.Thread.run(Thread.java:662)

          root cause

          org.apache.commons.discovery.DiscoveryException: Class org.apache.commons.logging.impl.SLF4JLogFactory does not implement org.apache.commons.logging.LogFactory
          org.apache.commons.discovery.tools.ClassUtils.verifyAncestory(ClassUtils.java:180)
          org.apache.commons.discovery.tools.SPInterface.verifyAncestory(SPInterface.java:201)
          org.apache.commons.discovery.tools.SPInterface.newInstance(SPInterface.java:195)
          org.apache.commons.discovery.tools.DiscoverClass.newInstance(DiscoverClass.java:579)
          org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:418)
          org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:378)
          org.apache.axis.components.logger.LogFactory$1.run(LogFactory.java:45)
          java.security.AccessController.doPrivileged(Native Method)
          org.apache.axis.components.logger.LogFactory.getLogFactory(LogFactory.java:41)
          org.apache.axis.components.logger.LogFactory.<clinit>(LogFactory.java:33)
          org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58)
          sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
          sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
          sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
          java.lang.reflect.Constructor.newInstance(Constructor.java:513)
          java.lang.Class.newInstance0(Class.java:355)
          java.lang.Class.newInstance(Class.java:308)
          org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
          org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
          org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
          org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
          java.lang.Thread.run(Thread.java:662)

          note The full stack trace of the root cause is available in the Apache Tomcat/6.0.35 logs.
          Apache Tomcat/6.0.35

          Show
          Robert Dzido
          added a comment - After installing (and configuring .properties file) I got error like this. Screenshot attached HTTP Status 500 - type Exception report message description The server encountered an internal error () that prevented it from fulfilling this request. exception javax.servlet.ServletException: Error instantiating servlet class org.eclipse.birt.report.servlet.ViewerServlet org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877) org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594) org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675) java.lang.Thread.run(Thread.java:662) root cause java.lang.ExceptionInInitializerError org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58) sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) java.lang.reflect.Constructor.newInstance(Constructor.java:513) java.lang.Class.newInstance0(Class.java:355) java.lang.Class.newInstance(Class.java:308) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877) org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594) org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675) java.lang.Thread.run(Thread.java:662) root cause org.apache.commons.discovery.DiscoveryException: Class org.apache.commons.logging.impl.SLF4JLogFactory does not implement org.apache.commons.logging.LogFactory org.apache.commons.discovery.tools.ClassUtils.verifyAncestory(ClassUtils.java:180) org.apache.commons.discovery.tools.SPInterface.verifyAncestory(SPInterface.java:201) org.apache.commons.discovery.tools.SPInterface.newInstance(SPInterface.java:195) org.apache.commons.discovery.tools.DiscoverClass.newInstance(DiscoverClass.java:579) org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:418) org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:378) org.apache.axis.components.logger.LogFactory$1.run(LogFactory.java:45) java.security.AccessController.doPrivileged(Native Method) org.apache.axis.components.logger.LogFactory.getLogFactory(LogFactory.java:41) org.apache.axis.components.logger.LogFactory.<clinit>(LogFactory.java:33) org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58) sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) java.lang.reflect.Constructor.newInstance(Constructor.java:513) java.lang.Class.newInstance0(Class.java:355) java.lang.Class.newInstance(Class.java:308) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877) org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594) org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675) java.lang.Thread.run(Thread.java:662) note The full stack trace of the root cause is available in the Apache Tomcat/6.0.35 logs. Apache Tomcat/6.0.35
          alice.paillard@valiantys.com
          added a comment - - edited

          Hi,

          Valiantys' prepackaged Birt viewer is configured with default paths that may not fit your environment:

          • POWERREPORT_HOME => C:\Valiantys\PowerReport
          • BIRT_TMP => C:\tmp\birt\documents_generated

          What do you see when you go to Birt's url with your web browser?
          You should get the same thing as screenshot-1.jpg.

          Show
          alice.paillard@valiantys.com
          added a comment - - edited Hi, Valiantys' prepackaged Birt viewer is configured with default paths that may not fit your environment: POWERREPORT_HOME => C:\Valiantys\PowerReport BIRT_TMP => C:\tmp\birt\documents_generated What do you see when you go to Birt's url with your web browser? You should get the same thing as screenshot-1.jpg .
          Robert Dzido
          added a comment -

          I checked and corrected BIRT variables. My BIRT screen looks like yours.
          I get error:
          HTTP Status 500 -

          type Exception report

          message

          description The server encountered an internal error () that prevented it from fulfilling this request.

          exception

          javax.servlet.ServletException: Error instantiating servlet class org.eclipse.birt.report.servlet.ViewerServlet
          org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
          org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
          org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
          org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
          java.lang.Thread.run(Thread.java:662)

          root cause

          java.lang.ExceptionInInitializerError
          org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58)
          sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
          sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
          sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
          java.lang.reflect.Constructor.newInstance(Constructor.java:513)
          java.lang.Class.newInstance0(Class.java:355)
          java.lang.Class.newInstance(Class.java:308)
          org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
          org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
          org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
          org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
          java.lang.Thread.run(Thread.java:662)

          root cause

          org.apache.commons.discovery.DiscoveryException: Class org.apache.commons.logging.impl.SLF4JLogFactory does not implement org.apache.commons.logging.LogFactory
          org.apache.commons.discovery.tools.ClassUtils.verifyAncestory(ClassUtils.java:180)
          org.apache.commons.discovery.tools.SPInterface.verifyAncestory(SPInterface.java:201)
          org.apache.commons.discovery.tools.SPInterface.newInstance(SPInterface.java:195)
          org.apache.commons.discovery.tools.DiscoverClass.newInstance(DiscoverClass.java:579)
          org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:418)
          org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:378)
          org.apache.axis.components.logger.LogFactory$1.run(LogFactory.java:45)
          java.security.AccessController.doPrivileged(Native Method)
          org.apache.axis.components.logger.LogFactory.getLogFactory(LogFactory.java:41)
          org.apache.axis.components.logger.LogFactory.<clinit>(LogFactory.java:33)
          org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58)
          sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
          sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
          sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
          java.lang.reflect.Constructor.newInstance(Constructor.java:513)
          java.lang.Class.newInstance0(Class.java:355)
          java.lang.Class.newInstance(Class.java:308)
          org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
          org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
          org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
          org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
          java.lang.Thread.run(Thread.java:662)

          note The full stack trace of the root cause is available in the Apache Tomcat/6.0.35 logs.
          Apache Tomcat/6.0.35

          Show
          Robert Dzido
          added a comment - I checked and corrected BIRT variables. My BIRT screen looks like yours. I get error: HTTP Status 500 - type Exception report message description The server encountered an internal error () that prevented it from fulfilling this request. exception javax.servlet.ServletException: Error instantiating servlet class org.eclipse.birt.report.servlet.ViewerServlet org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877) org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594) org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675) java.lang.Thread.run(Thread.java:662) root cause java.lang.ExceptionInInitializerError org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58) sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) java.lang.reflect.Constructor.newInstance(Constructor.java:513) java.lang.Class.newInstance0(Class.java:355) java.lang.Class.newInstance(Class.java:308) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877) org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594) org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675) java.lang.Thread.run(Thread.java:662) root cause org.apache.commons.discovery.DiscoveryException: Class org.apache.commons.logging.impl.SLF4JLogFactory does not implement org.apache.commons.logging.LogFactory org.apache.commons.discovery.tools.ClassUtils.verifyAncestory(ClassUtils.java:180) org.apache.commons.discovery.tools.SPInterface.verifyAncestory(SPInterface.java:201) org.apache.commons.discovery.tools.SPInterface.newInstance(SPInterface.java:195) org.apache.commons.discovery.tools.DiscoverClass.newInstance(DiscoverClass.java:579) org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:418) org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:378) org.apache.axis.components.logger.LogFactory$1.run(LogFactory.java:45) java.security.AccessController.doPrivileged(Native Method) org.apache.axis.components.logger.LogFactory.getLogFactory(LogFactory.java:41) org.apache.axis.components.logger.LogFactory.<clinit>(LogFactory.java:33) org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58) sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) java.lang.reflect.Constructor.newInstance(Constructor.java:513) java.lang.Class.newInstance0(Class.java:355) java.lang.Class.newInstance(Class.java:308) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877) org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594) org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675) java.lang.Thread.run(Thread.java:662) note The full stack trace of the root cause is available in the Apache Tomcat/6.0.35 logs. Apache Tomcat/6.0.35
          alice.paillard@valiantys.com
          added a comment -

          Did you correctly update powerReportConfiguration.properties:

          • reporting.directory.home.path
          • birt.viewer.webapp.url
          • birt.viewer.rptdocument.generated.path
          Show
          alice.paillard@valiantys.com
          added a comment - Did you correctly update powerReportConfiguration.properties : reporting.directory.home.path birt.viewer.webapp.url birt.viewer.rptdocument.generated.path
          Robert Dzido
          added a comment -

          corrected birt.viewer.webapp.url
          Still have error:

          HTTP Status 500 -

          type Exception report

          message

          description The server encountered an internal error () that prevented it from fulfilling this request.

          exception

          javax.servlet.ServletException: Error instantiating servlet class org.eclipse.birt.report.servlet.ViewerServlet
          org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
          org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
          org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
          org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
          java.lang.Thread.run(Thread.java:662)

          root cause

          java.lang.ExceptionInInitializerError
          org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58)
          sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
          sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
          sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
          java.lang.reflect.Constructor.newInstance(Constructor.java:513)
          java.lang.Class.newInstance0(Class.java:355)
          java.lang.Class.newInstance(Class.java:308)
          org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
          org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
          org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
          org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
          java.lang.Thread.run(Thread.java:662)

          root cause

          org.apache.commons.discovery.DiscoveryException: Class org.apache.commons.logging.impl.SLF4JLogFactory does not implement org.apache.commons.logging.LogFactory
          org.apache.commons.discovery.tools.ClassUtils.verifyAncestory(ClassUtils.java:180)
          org.apache.commons.discovery.tools.SPInterface.verifyAncestory(SPInterface.java:201)
          org.apache.commons.discovery.tools.SPInterface.newInstance(SPInterface.java:195)
          org.apache.commons.discovery.tools.DiscoverClass.newInstance(DiscoverClass.java:579)
          org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:418)
          org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:378)
          org.apache.axis.components.logger.LogFactory$1.run(LogFactory.java:45)
          java.security.AccessController.doPrivileged(Native Method)
          org.apache.axis.components.logger.LogFactory.getLogFactory(LogFactory.java:41)
          org.apache.axis.components.logger.LogFactory.<clinit>(LogFactory.java:33)
          org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58)
          sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
          sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
          sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
          java.lang.reflect.Constructor.newInstance(Constructor.java:513)
          java.lang.Class.newInstance0(Class.java:355)
          java.lang.Class.newInstance(Class.java:308)
          org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
          org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877)
          org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594)
          org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
          java.lang.Thread.run(Thread.java:662)

          note The full stack trace of the root cause is available in the Apache Tomcat/6.0.35 logs.
          Apache Tomcat/6.0.35

          Show
          Robert Dzido
          added a comment - corrected birt.viewer.webapp.url Still have error: HTTP Status 500 - type Exception report message description The server encountered an internal error () that prevented it from fulfilling this request. exception javax.servlet.ServletException: Error instantiating servlet class org.eclipse.birt.report.servlet.ViewerServlet org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877) org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594) org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675) java.lang.Thread.run(Thread.java:662) root cause java.lang.ExceptionInInitializerError org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58) sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) java.lang.reflect.Constructor.newInstance(Constructor.java:513) java.lang.Class.newInstance0(Class.java:355) java.lang.Class.newInstance(Class.java:308) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877) org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594) org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675) java.lang.Thread.run(Thread.java:662) root cause org.apache.commons.discovery.DiscoveryException: Class org.apache.commons.logging.impl.SLF4JLogFactory does not implement org.apache.commons.logging.LogFactory org.apache.commons.discovery.tools.ClassUtils.verifyAncestory(ClassUtils.java:180) org.apache.commons.discovery.tools.SPInterface.verifyAncestory(SPInterface.java:201) org.apache.commons.discovery.tools.SPInterface.newInstance(SPInterface.java:195) org.apache.commons.discovery.tools.DiscoverClass.newInstance(DiscoverClass.java:579) org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:418) org.apache.commons.discovery.tools.DiscoverSingleton.find(DiscoverSingleton.java:378) org.apache.axis.components.logger.LogFactory$1.run(LogFactory.java:45) java.security.AccessController.doPrivileged(Native Method) org.apache.axis.components.logger.LogFactory.getLogFactory(LogFactory.java:41) org.apache.axis.components.logger.LogFactory.<clinit>(LogFactory.java:33) org.apache.axis.transport.http.AxisServletBase.<clinit>(AxisServletBase.java:58) sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) java.lang.reflect.Constructor.newInstance(Constructor.java:513) java.lang.Class.newInstance0(Class.java:355) java.lang.Class.newInstance(Class.java:308) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293) org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:877) org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:594) org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675) java.lang.Thread.run(Thread.java:662) note The full stack trace of the root cause is available in the Apache Tomcat/6.0.35 logs. Apache Tomcat/6.0.35
          alice.paillard@valiantys.com
          added a comment -

          Can you attach to this issue:

          • a copy of your JIRA system info page
          • birt.xml
          • powerReportConfiguration.properties

          Can you upload reports in the JIRA gadget and do you see them in the list? You can use the example report attached to the documentation page Project_issues_priority_by_status.rptdesign.
          If yes, do you get error above for all output formats (Word, Excel...)?

          Show
          alice.paillard@valiantys.com
          added a comment - Can you attach to this issue: a copy of your JIRA system info page birt.xml powerReportConfiguration.properties Can you upload reports in the JIRA gadget and do you see them in the list? You can use the example report attached to the documentation page Project_issues_priority_by_status.rptdesign . If yes, do you get error above for all output formats (Word, Excel...)?
          Robert Dzido
          added a comment - - edited

          I'm attaching all requested files and birt's web.xml as well.
          JIRA is WAR version running on same tomcat as Birt (jira is in Context root, and birt in /birt context).
          All configuration and libraties are listed in attached pdf printout (screenshot too short)

          I can see powerreport gadget and upload reports. They're shown in list and are correctly copied to correct directories.
          Exports (PDF, Excel, Word) doesn't work as well.

          Show
          Robert Dzido
          added a comment - - edited I'm attaching all requested files and birt's web.xml as well. JIRA is WAR version running on same tomcat as Birt (jira is in Context root, and birt in /birt context). All configuration and libraties are listed in attached pdf printout (screenshot too short) I can see powerreport gadget and upload reports. They're shown in list and are correctly copied to correct directories. Exports (PDF, Excel, Word) doesn't work as well.
          alice.paillard@valiantys.com
          added a comment -

          Hi,

          You forgot to update parameter BIRT_RESOURCE_PATH in file web.xml.

          Alice

          Show
          alice.paillard@valiantys.com
          added a comment - Hi, You forgot to update parameter BIRT_RESOURCE_PATH in file web.xml . Alice
          Robert Dzido
          added a comment -

          BIRT_RESOURCE_PATH updated and still have similar error. Please find attached screenshot and updated web.xml

          Show
          Robert Dzido
          added a comment - BIRT_RESOURCE_PATH updated and still have similar error. Please find attached screenshot and updated web.xml
          alice.paillard@valiantys.com
          added a comment -

          You need to deploy the birt-viewer again to apply the update:

          • Shutdown tomcat
          • Delete directory birt probably located in C:/JIRA/webapps/
          • Delete directory birt probably located in C:/JIRA/work/Catalina/localhost/
          • Restart tomcat
          Show
          alice.paillard@valiantys.com
          added a comment - You need to deploy the birt-viewer again to apply the update: Shutdown tomcat Delete directory birt probably located in C:/JIRA/webapps/ Delete directory birt probably located in C:/JIRA/work/Catalina/localhost/ Restart tomcat
          Robert Dzido
          added a comment -

          Redeployed and still same error. Maybe it's something about conflict between SLF (Used by JIRA) and Log4J (used by birt)?

          Show
          Robert Dzido
          added a comment - Redeployed and still same error. Maybe it's something about conflict between SLF (Used by JIRA) and Log4J (used by birt)?
          alice.paillard@valiantys.com
          added a comment -

          When you go to birt's url with your web browser there is an 'Example' link.
          If you click it Birt tries to reach a 'test.rptdesign' report located in $Powerreport_home.

          Can you copy-paste Project_issues_priority_by_status.rptdesign into that location and rename it test.rptdesign.
          Then click the link again, you should see that report.

          Show
          alice.paillard@valiantys.com
          added a comment - When you go to birt's url with your web browser there is an 'Example' link. If you click it Birt tries to reach a 'test.rptdesign' report located in $Powerreport_home . Can you copy-paste Project_issues_priority_by_status.rptdesign into that location and rename it test.rptdesign . Then click the link again, you should see that report.
          Robert Dzido
          added a comment -

          I replaced test.rptdesign with your one and have same error directly in Birt.

          Show
          Robert Dzido
          added a comment - I replaced test.rptdesign with your one and have same error directly in Birt.
          alice.paillard@valiantys.com
          added a comment -

          So it means that there is something wrong in Birt setup that is not related to PowerReport.
          Can you ensure that Birt has read and write permissions on C:\\Atlassian\\JIRA\\PowerReport
          docs
          and C:\\Atlassian\\JIRA
          PowerReport
          ?

          Show
          alice.paillard@valiantys.com
          added a comment - So it means that there is something wrong in Birt setup that is not related to PowerReport. Can you ensure that Birt has read and write permissions on C:\\Atlassian\\JIRA\\PowerReport docs and C:\\Atlassian\\JIRA PowerReport ?
          Robert Dzido
          added a comment -

          I resolved it myself. As I suggested before problem occurs when BIRT and JIRA runs on same tomcat. JIRA uses some libraries (SLF) that can't be run together in one context with BIRT's ones (log4j). After reconfiguring tomcat libraries (not according to Atlassian documentation) it almost works fine. Only issue to resolve is that on your demonstration report I can't see parameters (issue type).

          Show
          Robert Dzido
          added a comment - I resolved it myself. As I suggested before problem occurs when BIRT and JIRA runs on same tomcat. JIRA uses some libraries (SLF) that can't be run together in one context with BIRT's ones (log4j). After reconfiguring tomcat libraries (not according to Atlassian documentation) it almost works fine. Only issue to resolve is that on your demonstration report I can't see parameters (issue type).
          alice.paillard@valiantys.com
          added a comment -

          Except that you can't filter by Issue type, is the report correctly displayed?

          Show
          alice.paillard@valiantys.com
          added a comment - Except that you can't filter by Issue type, is the report correctly displayed?
          Brice Gestas [Valiantys]
          added a comment -

          Hi Robert,

          Thanks for your feedback concerning the SLF4j libraries conflict between JIRA and BIRT running on the same Tomcat server. What did you do exactly to make it work (After reconfiguring tomcat libraries???)?

          To make the report work, you have to declare in your birt.xml context file the JNDI ressource with your JIRA Database settings as it is explained in the documentation => https://studio.plugins.atlassian.com/wiki/display/PWR/Installation+Guide#InstallationGuide-Installationsteps : this ressource has to be named JiraDS!

          Regards

          Show
          Brice Gestas [Valiantys]
          added a comment - Hi Robert, Thanks for your feedback concerning the SLF4j libraries conflict between JIRA and BIRT running on the same Tomcat server. What did you do exactly to make it work ( After reconfiguring tomcat libraries ???)? To make the report work, you have to declare in your birt.xml context file the JNDI ressource with your JIRA Database settings as it is explained in the documentation => https://studio.plugins.atlassian.com/wiki/display/PWR/Installation+Guide#InstallationGuide-Installationsteps : this ressource has to be named JiraDS ! Regards

            People

            • Assignee:
              Brice Gestas [Valiantys]
              Reporter:
              Robert Dzido
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: